Kengo Seki created HADOOP-12401:
-----------------------------------

             Summary: Wrong function names in test-patch bigtop personality
                 Key: HADOOP-12401
                 URL: https://issues.apache.org/jira/browse/HADOOP-12401
             Project: Hadoop Common
          Issue Type: Sub-task
          Components: yetus
    Affects Versions: HADOOP-12111
            Reporter: Kengo Seki


In dev-support/personality/bigtop.sh:

{code}
 51 function bigtop_precheck_postinstall
 52 {
 53   if [[ ${BIGTOP_PUPPETSETUP} = "true" ]]; then
 54     pushd "${BASEDIR}" >/dev/null
 55     echo_and_redirect "${PATCH_DIR}/bigtop-branch-toolchain.txt" 
"${GRADLEW}" toolchain
 56     popd >/dev/null
 57   fi
 58 }
 59 
 60 function bigtop_postapply_postinstall
 61 {
 62   if [[ ${BIGTOP_PUPPETSETUP} = "true" ]]; then
 63     pushd "${BASEDIR}" >/dev/null
 64     echo_and_redirect "${PATCH_DIR}/bigtop-patch-toolchain.txt" 
"${GRADLEW}" toolchain
 65     popd >/dev/null
 66   fi
 67 }
{code}

Their names are not proper for test-patch plugin callback functions. Maybe it 
should be like:

{code}
function bigtop_precompile
{
  declare codebase=$1
  if [[ ${BIGTOP_PUPPETSETUP} = "true" && ( ${codebase} = "branch" || 
${codebase} = "patch" ) ]]; then
    pushd "${BASEDIR}" >/dev/null
    echo_and_redirect "${PATCH_DIR}/bigtop-${codebase}-toolchain.txt" 
"${GRADLEW}" toolchain
    popd >/dev/null
  fi  
}
{code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to