[ 
https://issues.apache.org/jira/browse/HADOOP-13641?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15559424#comment-15559424
 ] 

Kai Zheng commented on HADOOP-13641:
------------------------------------

Oops, I thought the logic isn't correct. Previously if isKeytab is true, it 
will not spawn the thread and return. 
{code}
-    if (isSecurityEnabled()) {
-      //spawn thread only if we have kerb credentials
-      if (user.getAuthenticationMethod() == AuthenticationMethod.KERBEROS &&
-          !isKeytab) {
-        Thread t = new Thread(new Runnable() {
...
+    if (!isSecurityEnabled()
+      || user.getAuthenticationMethod() != AuthenticationMethod.KERBEROS
+      || !isKeytab) {
+      return;
+    }
{code}

> Update UGI#spawnAutoRenewalThreadForUserCreds to reduce indentation
> -------------------------------------------------------------------
>
>                 Key: HADOOP-13641
>                 URL: https://issues.apache.org/jira/browse/HADOOP-13641
>             Project: Hadoop Common
>          Issue Type: Improvement
>            Reporter: Xiao Chen
>            Assignee: Huafeng Wang
>            Priority: Minor
>              Labels: newbie
>         Attachments: HADOOP-13641.1.patch
>
>
> From [~drankye]'s comment in HADOOP-13590:
> Could we return earlier at the beginning so we can avoid at least 2 level of 
> indents and make the whole block more readable?
> {code}
>   /**Spawn a thread to do periodic renewals of kerberos credentials*/
>   private void spawnAutoRenewalThreadForUserCreds() {
>     if (isSecurityEnabled()) {
>       //spawn thread only if we have kerb credentials
>       if (user.getAuthenticationMethod() == AuthenticationMethod.KERBEROS &&
>           !isKeytab) {
> ...
> ...
>                              very deep nested ...
> ...
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: common-issues-h...@hadoop.apache.org

Reply via email to