Yasen Liu created HADOOP-14595:
----------------------------------

             Summary: Internal method has not been used, should be deleted or 
marked as unused
                 Key: HADOOP-14595
                 URL: https://issues.apache.org/jira/browse/HADOOP-14595
             Project: Hadoop Common
          Issue Type: Improvement
            Reporter: Yasen Liu
            Priority: Trivial


i found the method is unused  method,and is internal implementation.In order to 
keep the code clean,I think it should be deleted or marked as unused.

/**
   * internal implementation of directory creation.
   *
   * @param path path to file
   * @return boolean file is created; false: no need to create
   * @throws IOException if specified path is file instead of directory
   */
  private boolean mkdir(Path path) throws IOException {
    Path directory = makeAbsolute(path);
    boolean shouldCreate = shouldCreate(directory);
    if (shouldCreate) {
      forceMkdir(directory);
    }
    return shouldCreate;
  }



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: common-issues-h...@hadoop.apache.org

Reply via email to