[ 
https://issues.apache.org/jira/browse/HADOOP-13485?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16299524#comment-16299524
 ] 

Xiao Chen commented on HADOOP-13485:
------------------------------------

I have not worked on azure much, but this patch looks pretty straightforward.

1 question: is there a reason we specifically log a message about block size, 
instead of combining the 2 messages? I'd prefer these to be 1 message unless 
there's a strong reason for the current way.
{code}
LOG.debug("NativeAzureFileSystem. Initializing.");
LOG.debug("  blockSize  = {}", this.blockSize);
{code}

Added both [~vrushalic] and [~hengli...@gmail.com] to Hadoop contributors, so 
you can feel free to assign the jira to yourself and attach patches in the 
future.

> Log refactoring: method invocation should be replaced by variable in hadoop 
> tools
> ---------------------------------------------------------------------------------
>
>                 Key: HADOOP-13485
>                 URL: https://issues.apache.org/jira/browse/HADOOP-13485
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: tools
>    Affects Versions: 2.7.2
>            Reporter: Nemo Chen
>              Labels: easy
>         Attachments: HADOOP-13485.001.patch
>
>
> Similar to the fix for HDFS-409. In file:
> hadoop-rel-release-2.7.2/hadoop-tools/hadoop-azure/src/main/java/org/apache/hadoop/fs/azure/NativeAzureFileSystem.java
> {code:borderStyle=solid}
> this.blockSize = conf.getLong(AZURE_BLOCK_SIZE_PROPERTY_NAME,
>         MAX_AZURE_BLOCK_SIZE);
> if (LOG.isDebugEnabled()) {
>     LOG.debug("NativeAzureFileSystem. Initializing.");
>     LOG.debug("  blockSize  = "
>           + conf.getLong(AZURE_BLOCK_SIZE_PROPERTY_NAME, 
> MAX_AZURE_BLOCK_SIZE));
> }
> {code}
> For simplicity and readability, the 
> {{conf.getLong(AZURE_BLOCK_SIZE_PROPERTY_NAME, MAX_AZURE_BLOCK_SIZE))}} 
> should be changed to {{this.blockSize}}.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: common-issues-h...@hadoop.apache.org

Reply via email to