[ 
https://issues.apache.org/jira/browse/HADOOP-15954?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16758661#comment-16758661
 ] 

Da Zhou commented on HADOOP-15954:
----------------------------------

After reconsideration, we decided not to make the Identity transformer a plugin 
mode at this moment. So I revert it back from an interface to a normal class.
The main reason are: 
*1*. The proposed interface lead to performance issue, it forced the ABFS to 
always do extra allocation (eg: In getFileStatus(), need to always create file 
status and then pass it to transformer, which might create new FileStatus if 
the identity needs to be transformed.)
*2*.Changing the interface to focus on only own/group transformation can help, 
but the interface becomes complex and less flexible for users, which betrays 
the original goal.

Submitting patch 013, changes are:
1. Removed the interface.
1. Move the UsergroupInformation  parsing and exception handling to 
AzureBlobFileSystemStore() to avoid duplicate code and inconsistent local 
owner, group located in AzureBlobFileSystem and IdentityTransformer. 
2. Refactored  "IdentityTransformer" to make it more readable.
3. Unit tests are added for each identity transformation scenario. 



> ABFS: Enable owner and group conversion for MSI and login user using OAuth
> --------------------------------------------------------------------------
>
>                 Key: HADOOP-15954
>                 URL: https://issues.apache.org/jira/browse/HADOOP-15954
>             Project: Hadoop Common
>          Issue Type: Sub-task
>          Components: fs/azure
>    Affects Versions: 3.2.0
>            Reporter: junhua gu
>            Assignee: Da Zhou
>            Priority: Major
>         Attachments: HADOOP-15954-001.patch, HADOOP-15954-002.patch, 
> HADOOP-15954-003.patch, HADOOP-15954-004.patch, HADOOP-15954-005.patch, 
> HADOOP-15954-006.patch, HADOOP-15954-007.patch, HADOOP-15954-008.patch, 
> HADOOP-15954-009.patch, HADOOP-15954-010.patch, HADOOP-15954-011.patch, 
> HADOOP-15954-012.patch
>
>
> Add support for overwriting owner and group in set/get operations to be the 
> service principal id when OAuth is used. Add support for upn short name 
> format.
>  
> Add Standard Transformer for SharedKey / Service 
> Add interface provides an extensible model for customizing the acquisition of 
> Identity Transformer.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: common-issues-h...@hadoop.apache.org

Reply via email to