[ https://issues.apache.org/jira/browse/HADOOP-8957?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13491905#comment-13491905 ]
Sanjay Radia commented on HADOOP-8957: -------------------------------------- * You have added viewFS#resolveFromFSState where you validate the path for mounts ** The mounted file systems will validate the path names anyway - so is this necessary? ** What about validating internal names (ie within the mounted) which your patch does not. *** Add a test for that. *** One could argue that the pathname validity check for internal names is needed *only* when the mount table is created, since illegal names will not match to any internal names within the mount table. This translates to whether one wants IllegalNameException or PathNotFoundException when the user does open("illegal:path"). I think your patch returns PathNotFoundException for internal names that are illegal. ** You didn't use resolveFromFSState in ViewFileSystem? Shouldn't ViewFs and ViewFileSystem be consistent? ** Minor - a better name would have been validatePathAndResolve * AbstractFileSystem#isValidName - Being able to override isValidName makes sense but the default impl should not return true; instead the default impl should be the code needed by HDFS -- file systems that need a different impl can override this method. > FileContext.getFileContext causes multiple test failures on Windows due to > InvocationTargetException > ---------------------------------------------------------------------------------------------------- > > Key: HADOOP-8957 > URL: https://issues.apache.org/jira/browse/HADOOP-8957 > Project: Hadoop Common > Issue Type: Bug > Components: fs > Affects Versions: 3.0.0, trunk-win > Reporter: Chris Nauroth > Assignee: Chris Nauroth > Attachments: HADOOP-8957.patch, HADOOP-8957.patch > > > This appears to be a problem with parsing a Windows-specific path, ultimately > throwing InvocationTargetException from AbstractFileSystem.newInstance. -- This message is automatically generated by JIRA. If you think it was sent incorrectly, please contact your JIRA administrators For more information on JIRA, see: http://www.atlassian.com/software/jira