[ 
https://issues.apache.org/jira/browse/HADOOP-12398?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14739919#comment-14739919
 ] 

Kengo Seki commented on HADOOP-12398:
-------------------------------------

[~jagadesh.kiran] Yes, that function is intended to be called from 
test-patch.sh. But because of its name, it won't be called. [As yetus precommit 
document 
explains|https://github.com/apache/hadoop/blob/HADOOP-12111/dev-support/docs/precommit-advanced.md#test-plug-ins],
 plugin name is passed to test-patch.sh via add_plugin function. In this case, 
the plugin name is "flinklib":

{code}
 26 add_plugin flinklib
{code}

so the function name should be  "flinklib_filefilter". Could you rename the 
function rather than remove it? Thanks.

> filefilter function in test-patch flink personality is never called
> -------------------------------------------------------------------
>
>                 Key: HADOOP-12398
>                 URL: https://issues.apache.org/jira/browse/HADOOP-12398
>             Project: Hadoop Common
>          Issue Type: Sub-task
>          Components: yetus
>    Affects Versions: HADOOP-12111
>            Reporter: Kengo Seki
>            Assignee: Jagadesh Kiran N
>              Labels: newbie
>         Attachments: HADOOP-12398.HADOOP-12111.00.patch
>
>
> Wrong function name.
> {code}
>  28 function fliblib_filefilter
>  29 {
>  30   local filename=$1
>  31 
>  32   if [[ ${filename} =~ \.java$
>  33     || ${filename} =~ \.scala$
>  34     || ${filename} =~ pom.xml$ ]]; then
>  35     add_test flinklib
>  36   fi
>  37 }
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to