On Tue, 11 Mar 2003, Stephen Colebourne wrote:

> The type-limited collection concept is probably the most common of the
> predicate implementations. It was also the one from which predicated
> collections were born. Although this patch will not really add any new
> functionality to [collections], it will significantly aid code readability
> in a common case. That is enough for me, although I should make it clear
> that I would not support every addition of this kind.
>
> I would like to commit this, are you casting a vote?

No worse than -0.  I agree it's the most common case, personally I find
the predicatedBag form more readable.

> Stephen
>
> ----- Original Message -----
> From: "Rodney Waldhoff" <[EMAIL PROTECTED]>
> > Can someone clarify the advantage of:
> >
> >  typedBag(bag, String.class)
> >
> > over
> >
> >  predicatedBag(bag, new InstanceofPredicate(String.class));
> >
> > ?
> >
> > On Mon, 11 Mar 2003, grumpoxl wrote:
> >
> > > The patches will take more than one message due to the size limit.
> > >
> > > I added typedXXX(Collection, Class) and typedXXX(Class) methods in each
> > > of the Utils classes.
> > >
> > > I added some test cases for typedXXX, which were pretty close copies of
> > > the tests for predicatedXXX.  I didn't see any tests for BagUtils.
> > >
> > > I may have accidentally hit the "format" command in Eclipse while
> > > editing MapUtils and TestCollectionUtils, that is why the patch files
> > > are so large.  If necessary, I can redo those changes on a fresh
> > > version.
> > >
> > > A desire for predicatedXXX(Predicate) methods in the Utils classes was
> > > mentioned before.  If all of these changes can be committed... I can
> > > submit patches for those soon after.
> > >
> > > Thanks, let me know if there are any problems.
> > >
> > >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: [EMAIL PROTECTED]
> > For additional commands, e-mail: [EMAIL PROTECTED]
> >
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [EMAIL PROTECTED]
> For additional commands, e-mail: [EMAIL PROTECTED]
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]

Reply via email to