Harish's suggestion:

<service id=> --> <service-point id=>
<extend-service service-id=> --> <service service-id=>
<extension-point id=> --> <configuration-point id=>
<extension point-id=> --> <configuration point-id=>

Everyone seems pretty keen on this.

I have minor reservations about <service> not quite capturing what the element does.  
I agree that
<extend-service> has some unwanted connotations.  <provide-service> perhaps? At one 
time it was
<contribute-service>.

Last point was the excessive simularity of <configuration-point id="..."> and 
<configuration
point-id="...">.

Perhaps that should be <configuration for-point-id="..."> to help distinguish the two 
visually? An
earlier version was <contribute-configuration> but damn thats long.

Alternately, here's my suggestion:

<service> --> <define-service-point>
<extend-service> --> <service>
<extension-point> --> <define-configuration-point>
<extension> --> <configuration>




--
Howard M. Lewis Ship
Creator, Tapestry: Java Web Components
http://jakarta.apache.org/tapestry
http://jakarta.apache.org/commons/sandbox/hivemind/
http://javatapestry.blogspot.com


---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]

Reply via email to