>
> So the battle has become:
>
> o.a.c.primitives.boolean
> o.a.c.primitives.byte
> o.a.c.primitives.short
> o.a.c.primitives.int
> o.a.c.primitives.long
> o.a.c.primitives.float
> o.a.c.primitives.double
>
> vs.
>
> o.a.c.primitives.collection
> o.a.c.primitives.list
> o.a.c.primitives.iterator
> o.a.c.primitives.map
>
>
> Any other opinions?
>

To my knowledge, the type based packaging as presented is not possible.
boolean, byte, short, et al are Java keywords and can not be used as parts
of a package name.  So, if a type based approach is to be employed,
convoluted names for primitive types would need to be used instead of their
conventional names.  With that, I would say, the collection based approach
is clearly the better alternative.

Brent Worden
http://www.brent.worden.org


---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]

Reply via email to