I'm actually +1 *only* if we make the minor API changes that I suggested
last week. These changes are to the new caching API:

* Change setTagForScript in JellyContext to setScriptData. This method
should take a key of type Script, not TagScript.
* Also in JellyContext, change the name of tagHolderMap to scriptData. It
shouldn't be a WeakHashMap.
* All access to the scriptData map should be through a protected method
getScriptDataMap
* Separate the clearing of script data into a method clearScriptData,
leaving the clear method to its original meaning.


If it's OK with all, I'll commit these changes today.

Also, I'll make the script data cache thread safe... which will mean that
you have to clear the cache from the thread that invoked it. This will
preserve the threading guarantees for Tag implementations.

I'll do this today, too.

Hans


-----Original Message-----
From: Corey Scott [mailto:[EMAIL PROTECTED] 
Sent: Monday, January 17, 2005 4:12 AM
To: Jakarta Commons Developers List
Subject: [Email] To release or not to release

Can someone with commit priviledge please change email over from RC1 to
v.1.0?

The RC has been out for quite a while now and so far there are no
complaints about this.

There are several other things waiting for this release, e.g. a
proposed change to the jelly email classes (change to Commons Email)
and some proposed extensions to Email itself, so completing the
release would be greatly appreciated.

Many Thanks,
Corey

---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]


---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]

Reply via email to