On Thu, 19 May 2005, Brett Porter <[EMAIL PROTECTED]> wrote:

> Thanks Stefan - feedback inline.

Oh my time flies when you are having fun, not.  Sorry for the delay
(again).

> These all look fine for most uses, but I would like a default
> implementation that builds on something like this:
> 
> interface PgpSignatureUpdater {
>   void update( byte[] data )
>   void update( byte[] data, int offset, int length )
>   byte[] finish()
> }
> 
> This being used to create the detached signature (I'm assuming a
> generated detached signature can be later added to the actual
> message, and that byte[] is sufficient for both binary and ascii
> armored output),

I think you can't mix unarmored and armored data, but I'm not sure.
Honestly I'm not even sure you can combine the signature and the
payload at all.

The interface is fine with me.

> The implementation would take configuration specifying the keyring,
> ascii armoring and anything else.

OK.

>>And finally
>>
>>class FooFactory {
>>     static FooFactory getFactory() throws PGPException;
>>     Foo newFoo() throws PGPException;
>>}
>>
>>Foo is a placeholder since (1) I can't come up with a good name
>>right now and (2) have a long track record of inventing bad names
>>anyway.
>>
> PgpSigner and PgpSignatureVerifier (I can't think of a unified name
> without coffee).

I still can't, even after several litres of coffee between my original
mail and now.  Anybody else?

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]

Reply via email to