Hello:

This seems reasonable but I wonder if it wouldn't be nice to have API
names that are similar to BigInteger (and AtomicInteger.) For example,
we could have "add" and "substract", instead of "addValue" and
"substactValue".

Gary

> -----Original Message-----
> From: Stephen Colebourne [mailto:[EMAIL PROTECTED]
> Sent: Sunday, March 19, 2006 4:36 PM
> To: Jakarta Commons Developers List
> Subject: [lang] Mutable* increment decrement, add and subtract
> 
> I would like to add the following methods to the Mutable* number
classes
> 
> - increment
> - decrement
> - addValue(int/short/...)
> - addValue(Number)
> - subtractValue(int/short/...)
> - subtractValue(Number)
> 
> Only question is whether we should try to catch overflow conditions or
> not. That could get quite complex.
> 
> Stephen
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [EMAIL PROTECTED]
> For additional commands, e-mail: [EMAIL PROTECTED]
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]

Reply via email to