On 11 Dec 2015, at 11:17, Alan Bateman <alan.bate...@oracle.com> wrote:
> On 11/12/2015 09:24, Chris Hegarty wrote: >> : >>> Nit: >>> 687 * the specified <i>stack size</i>, and inherits initial values for >>> Not sure if italic font of stack size is intentional since this constructor >>> doesn't emphasize on this parameter. >> Right, replaced with: >> * the specified {@code stackSize}, and inherits initial values for >> > The latest webrev looks good to me. Thanks for the review. > One small thing is that this patch chooses names for internal threads that > didn't previously have useful names. In the case of fs.AbstractPoller and > fs.PollingWatchService then "FileSystemWatchService" would be clearer. For > WindowsSelectorImpl then "SelectorHelper" might be clearer. Cancellable is > probably okay for now but it's too generic and probably needs a useful name > to be passed in via runInterruptibly. I updated the names with your suggestions, in-place in the latest webrev.. -Chris.