On 5/13/16 1:24 PM, Alan Bateman wrote:
On 13/05/2016 19:49, Xueming Shen wrote:
something like this?
http://cr.openjdk.java.net/~sherman/8147588/webrev/
Along these lines, yes.
Would it be cleaner if ZipFile_openAndDelete were rename to
ZipFile_open and used ZFILE_Open in libzip instead of
winFileHandleOpen in libjava? Also given the platforms and modes then
would it be simpler to use use ZFILE_Open for all platforms/cases.
My memory suggests the reason we went to winFileHandleOpen() is for that
windows' long path issue
we dealt with years ago. ZFILE_Open() does not appear to deal with that.
Sure I can bring ZFILE_Open in for the non-windows platform, though my
original wish is to reduce the
native exposure of the ZipFile. I don't have a strong feeling for that
though.
Should JavaIORandomAccessFileAccess.open be renamed to wrap as it does
not open the file?
It means to "open" an RandomAccessFile object, how about "create"?
"wrap" a little indicates the
RandomAccessFile does not nothing but only a wrapper around the "fd".
-Sherman