On Wed, 23 Sep 2020 17:41:49 GMT, Ian Graves <[email protected]> wrote:
>> I'll shrink narrow those descriptions down to 80 characters. >> >> As to the abstract class, I think it'd make sense to have that implement >> getUsage, getName, and getDescription -- >> essentially combine all of those very similar things in the same place. > > Updated to consolidate documentation/resource-related methods into an > abstract base class and shortened the mentioned > usage bodies to 80 chars or less. AbstractPlugin might be a better name for the abstract class as it will likely define methods beyond access to name, description and usage. It also needs a copyright header. StripNativeDebugSymbolsPlugin may have been missed in the update, it can extend the abstract class too. AddResourcePlugin: the name field can be removed, also should be good to rename "n" to "name" so it's a bit clearer. TaskHelper - the IDE may have messed up the imports when it was edited. ------------- PR: https://git.openjdk.java.net/jdk/pull/305
