Thanks for clarifying this. So my understanding of the versions in Juno was
obviously wrong. Of course it makes sense to include only one version in
the repository. Will there be an alternative aggregation repository for the
3.8 release to install compatible software from?

This probably also means that we won't get Jetty 8 in Eclipse 3.8, since
new features only go into the 4.x stream, right?
I guess the solution will be to base RAP on 4.2 already. I'm not sure about
the implications yet but we'll figure out until M4.

BTW, the reason why RAP is tightly coupled to the platform is simply that
we provide alternative implementations for platform APIs that run with our
web widget toolkit.

Regards, Ralf


On Tue, Nov 8, 2011 at 18:39, David M Williams <[email protected]>wrote:

>  Technically speaking, I do not think it is accurate to say "3.8 is still
> part of Juno". Yes, there will be a 3.8 released at the same time as Juno,
> but don't believe anyone has planned for it to be part of the common repo.
> That might be technically possible ... but, might also take more work to
> make sure there are not unusual interactions and problems introduced.
>
> That said, your desire to have a single stream that handles both is
> understandable so, not sure that the solution is. I do think you (RAP) have
> a special case since for reasons I've never understood (but am sure they
> are valid) have a very tight coupling with the Platform versions. Given
> that tight coupling, you might have to have two streams to support both
> versions of the platform?
>
> Hopefully others will have more constructive advice ... I just wanted to
> clarify that part about "3.8 being part of Juno".
>
> [Just read Christian's response after writing, but before hitting send ...
> so, "yes, Christian's right" :) ]
>
>
>
> [image: Inactive hide details for Ralf Sternberg ---11/08/2011 11:37:38
> AM---Hi, the RAP M3 contribution causes a conflict with the Jun]Ralf
> Sternberg ---11/08/2011 11:37:38 AM---Hi, the RAP M3 contribution causes a
> conflict with the Juno aggregator
>
> From: Ralf Sternberg <[email protected]>
> To: Cross project issues <[email protected]>,
> Date: 11/08/2011 11:37 AM
> Subject: [cross-project-issues-dev] 3.8 bundles in Juno
> Sent by: [email protected]
> ------------------------------
>
>
>
> Hi,
>
> the RAP M3 contribution causes a conflict with the Juno aggregator
> build, which I'm not quite sure how to tackle. The problem is that we
> have a feature that contains the requirements for a basic RAP target.
> These bundles are taken from 3.8M3 (since RAP is still based on 3.x).
> We provide this feature to make it easy for beginners to setup a
> complete RAP target. This went well so far, but now 4.2 seems to
> diverge from 3.8 and our 3.8 bundles clash with the 4.2 ones. I didn't
> expect those problems as 3.8 is still part of Juno.
>
> So here are my questions:
> Is it true that the aggregator build is now based on 4.2 and that 3.8
> is not part of it anymore?
> If so, does this mean that we just can't include any bundles from 3.8
> in the Juno repository anymore?
>
> As a quick fix, I disabled the problematic feature for now. This way,
> RAP itself is still part of M3, but a target must be assembled
> manually.
>
> Regards, Ralf
>
>
> On Tue, Nov 8, 2011 at 14:55, David Williams 
> <*[email protected]*<[email protected]>>
> wrote:
> > The following errors occured when building Juno:
> >
> > Software being installed: validationSet_main 1.0.0
> >
> > Only one of the following can be installed at once:
> [org.eclipse.equinox.http.registry 1.1.100.v20111010-1614,
> org.eclipse.equinox.http.registry 1.1.100.v20110502]
> >
> > Cannot satisfy dependency:
> mappedRepo_download.eclipse.org_eclipse_updates_4.2milestones_S-4.2M3-201110281100
> 1.0.0 depends on: org.eclipse.sdk.feature.group
> 4.1.0.v20110612-1800-7T7jA7F8Yx_b_g7iQ1Lsy1jM8NC4BSMUny-agK5mAGqK0
> >
> > Cannot satisfy dependency:
> mappedRepo_home_data_httpd_download.eclipse.org_rt_rap_1.5_runtime_M3-20111108-1014
> 1.0.0 depends on: org.eclipse.rap.runtime.requirements.feature.group
> [1.5.0,1.6.0)
> >
> > Cannot satisfy dependency: org.eclipse.help.feature.group
> 1.3.0.v20110809-0800-7i7uFLyFFt6Zqoimz0Bbd48R depends on:
> org.eclipse.equinox.http.registry [1.1.100.v20111010-1614]
> >
> > Cannot satisfy dependency:
> org.eclipse.rap.runtime.requirements.feature.group 1.5.0.20111108-1028
> depends on: org.eclipse.equinox.http.registry [1.1.100.v20110502]
> >
> > Cannot satisfy dependency: org.eclipse.sdk.feature.group
> 4.1.0.v20110612-1800-7T7jA7F8Yx_b_g7iQ1Lsy1jM8NC4BSMUny-agK5mAGqK0 depends
> on: org.eclipse.help.feature.group
> [1.3.0.v20110809-0800-7i7uFLyFFt6Zqoimz0Bbd48R]
> >
> > Cannot satisfy dependency: validationSet_main 1.0.0 depends on:
> mappedRepo_download.eclipse.org_eclipse_updates_4.2milestones_S-4.2M3-201110281100
> [1.0.0]
> >
> > Cannot satisfy dependency: validationSet_main 1.0.0 depends on:
> mappedRepo_home_data_httpd_download.eclipse.org_rt_rap_1.5_runtime_M3-20111108-1014
> [1.0.0]
> >
> > Check the log file for more information: *
> https://hudson.eclipse.org/hudson/view/Repository%20Aggregation/job/juno.runAggregator/124/console
> *<https://hudson.eclipse.org/hudson/view/Repository%20Aggregation/job/juno.runAggregator/124/console>
> >
> >
> _______________________________________________
> cross-project-issues-dev mailing list
> [email protected]
> https://dev.eclipse.org/mailman/listinfo/cross-project-issues-dev
>
>
> _______________________________________________
> cross-project-issues-dev mailing list
> [email protected]
> https://dev.eclipse.org/mailman/listinfo/cross-project-issues-dev
>
>

<<graycol.gif>>

_______________________________________________
cross-project-issues-dev mailing list
[email protected]
https://dev.eclipse.org/mailman/listinfo/cross-project-issues-dev

Reply via email to