On Fri, Jan 29, 2021 at 03:10:09PM -0800, Simon J. Gerraty wrote:
 > > It should probbaly suffice to call Job_CatchChildren after a SIGCHLD.
 > > It is a common misstake to assume that SIGCHLD will be receieved for each
 > > child - which is why looping in Job_CatchChildren is important.
 > > This means there will always be a wasted waitpid per call to
 > > Job_CatchChildren. 
 > 
 > The following is a minimal patch that should mitigate the waitpid calls
 > suggestions for better names welcome.
 >   :
 >  static sigset_t caught_signals;     /* Set of signals we handle */
 > +static volatile int reap_children;

"static volatile sig_atomic_t reap_children;"

but also, I would expect that this childExitJob.outPipe can go away.

-- 
David A. Holland
dholl...@netbsd.org

Reply via email to