El 04/06/13 16:55, Ed Leafe escribió:
On Jun 4, 2013, at 2:30 PM, Ricardo Aráoz <ricar...@gmail.com> wrote:

  I tried running a quick test, but it looks like dRadioList doesn't deal with 
grid sizers very well - the _checkSizer() method expects regular sizers. I 
don't know how that changed, since one of the goals for creating dRadioList was 
to allow for arrangements other than linear.
I'm getting : TypeError: Invalid keyword arguments passed to dGridSizer: 
Caption, orientation
        Well, that's exactly what I meant by my comment about grid sizers not 
working well.

So as soon as I can find out how to properly call super(), I was planning on 
subclassing dGridSizer and intercepting those arguments and see what happens.
        Not necessary - the problem is that these are passed rather than set 
directly. Change the _checkSizer() method to look like this:

        https://gist.github.com/EdLeafe/5709017

        BTW, pasting your code into a gist on GitHub is more readable than the 
way it comes through in an email.


Noted, will get a GitHub account.

Modified dRadioList.py and there seems to be something really wrong here.
No more errors. After instantiating the dRadioList with SizerClass=dabo.ui.dGridSizer parameter referenced by rlPuertos, I do rlPuertos.Sizer.MaxCols = 2. When I run the program the Choices list is shown in only one column, and in the command window if I ask for self.radioLstPuertos.Sizer.MaxCols I get a 2, self.radioLstPuertos.Sizer.Cols gives me 13, and self.radioLstPuertos.SizerClass gives <class 'dabo.ui.uiwx.dGridSizer.dGridSizer'>



--- StripMime Report -- processed MIME parts ---
multipart/alternative
 text/plain (text body -- kept)
 text/html
---
_______________________________________________
Post Messages to: Dabo-users@leafe.com
Subscription Maintenance: http://mail.leafe.com/mailman/listinfo/dabo-users
Searchable Archives: http://leafe.com/archives/search/dabo-users
This message: http://leafe.com/archives/byMID/51ae5e8a.6090...@gmail.com

Reply via email to