On  9.07.2010 00:41, John Scoles wrote:
Hi Luben

I have incorporated your patch into the DRCP branch and I have also merged
that branch back into trunk for any testing that you will be doing I would
try it with the Trunk which you can find here

http://svn.perl.org/modules/dbd-oracle/trunk

I went with the ORA_DRCP_* for the attribute names rather than POOL.

as well I made ORA_DRCP_CLASS an optional value.  Some users my not want to
use it.

Thanks again

John Scoles

Nice, this are better names. Here comes a patch to suppress warnings in scripts that are invoked with "perl -w"

luben
Index: Oracle.pm
===================================================================
--- Oracle.pm   (revision 14240)
+++ Oracle.pm   (working copy)
@@ -189,10 +189,10 @@
            } split /\s*;\s*/, $dbname;
            my %dbname = ( PROTOCOL => 'tcp', @dbname );
 
-            if ($dbname{SERVER} eq "POOLED") {
-               $attr->{ora_drcp}=1;
-         
+        if ((exists $dbname{SERVER}) and ($dbname{SERVER} eq "POOLED")) {
+            $attr->{ora_drcp}=1;
            }
+
            # extract main attributes for connect_data portion
            my @connect_data_attr = qw(SID INSTANCE_NAME SERVER SERVICE_NAME );
            my %connect_data = map { ($_ => delete $dbname{$_}) }

Reply via email to