Aaron, Ilja,

Been looking into the ldap code to see how much work it is to finish this code.

First off, I see a couple of functions that access userdata currently implemented in db.c:

accessing dbmail_users:

db_get_quotum_used
db_set_quotum_used
db_add_quotum_used
db_check_quotum_used
db_calculate_quotum_all
db_get_users_from_clientid
db_icheck_mailboxes
db_acl_get_identifiers

accessing dbmail_aliases:

db_get_deliver_from_aliases
db_addalias
db_addalias_ext
db_removealias
db_removealias_ext
db_get_user_aliases

I'm guessing these should probably be renamed, moved to auth/authsql.c and also be implementated in authldap.c, right? Of course, some of them (db_calculate_quotum_all) are not quite so straight forward.
Am I missing anything really obvious here?

I'm therefor proposing that all functions accessing userdata should become part of the auth-module.

Agree?

--
  ________________________________________________________________
  Paul Stevens                                  mailto:[EMAIL PROTECTED]
  NET FACILITIES GROUP                     PGP: finger [EMAIL PROTECTED]
  The Netherlands________________________________http://www.nfg.nl

Reply via email to