Package: live-build
Version: 1:20191221
Owner: jnq...@gmail.com
Severity: wishlist

the Restore_cache() and Save_cache() functions are misleading in their
names; they are specifically for handling **packages** kept in the
cache. they could do with renaming to help understandability of the
code.

furthermore their use is overly verbose. **every** use is with a param
of the form "cache/packages.binary" or "cache/packages.chroot". there
is obviously a common prefix here which could be eliminated.

patch(es) to be submitted via salsa soon

Reply via email to