Package: python-apt
Version: 0.7.5
Severity: normal

The coding style guide for Python 
<URL:http://www.python.org/dev/peps/pep-0008> is also a convention for 
code in the Python community.

Please rename the API methods of python-apt to conform with PEP 8 
guidelines. E.g.:

* 'apt.SizeToString' is a function, so should be named 
  'apt.size_to_string'

* 'apt.package.Package.markKeep' is a method, so should be named 
  'apt.package.Package.mark_keep'

* 'apt.cache.FilteredCache.filterCachePostChange' should be named
  'apt.cache.FilteredCache.filter_cache_post_change'

* 'apt.package.Dependency.candidateInstalledSize' is an attribute, so 
  should be named 'apt.package.Dependency.candidate_installed_size'

I'm happy to create patches to address this bug if that would be 
useful.



-- 
To UNSUBSCRIBE, email to [EMAIL PROTECTED]
with a subject of "unsubscribe". Trouble? Contact [EMAIL PROTECTED]

Reply via email to