On Wed, 28 Dec 2011, Kees Cook wrote:
> Adjusted. Refreshed patches attached...

I just merged them with a few tweaks:
- some rewording of the commit short descriptions
- some small style adjustments

> +sub set_feature {
> +    my ($self, $area, $feature, $enabled) = @_;
> +    $self->{features}->{$area}->{$feature} = !!$enabled;
> +}

Here I dropped the intermediary "->" that are not needed, and I dropped
the "!!" too, we don't really need to standardize the value, what matters
is how it evaluates in boolean context.

> +    # Store the feature usage.
> +    for (keys %use_feature) {
> +     $flags->set_feature("hardening", $_, $use_feature{$_})
> +    }

I changed this for better readability:
+    # Store the feature usage.
+    while (my ($feature, $enabled) = each %use_feature) {
+       $flags->set_feature("hardening", $feature, $enabled);
+    }

> +    if ($build_flags->has_features($param)) {
> +     my %features = $build_flags->get_features($param);
> +     my $para_shown = 0;
> +     foreach my $feature (sort keys %features) {
> +         if ($para_shown) {
> +             print "\n";
> +         } else {
> +             $para_shown = 1;
> +         }

Changed those last 5 lines to “print $para_shown++ ? "\n" : "";”.

Thanks for your work !

Cheers,
-- 
Raphaël Hertzog ◈ Debian Developer

Pre-order a copy of the Debian Administrator's Handbook and help
liberate it: http://debian-handbook.info/liberation/



--
To UNSUBSCRIBE, email to debian-dpkg-bugs-requ...@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmas...@lists.debian.org

Reply via email to