On Monday 21 April 2003 22:59, Matthias Klose wrote: > Arnd Bergmann writes: > > See also Bug#189350 for the required binutils patch.# ignore 64 bit > > shlibdeps for now, as on s390 and sparc64 > > you do this for libgcc1 and libstdc++5 only. Yes, that was an accident.
> maybe it's time to build > extra "64" packages. Is there already a naming convention for these > packages (i.e. libgcc164 or libgcc1-64)? glibc currently uses the names 'libc6-s390x' and 'libc6-dev-s390x' (and s/s390x/sparc64/), but that scheme does not scale well. Wichert Akkerman proposed using 'lib64gcc1', which I think is far better than the other proposals. AFAIK, neither Red Hat nor SuSE have invented a specific naming convention so far, so we can't choose a 'compatible' scheme. > > --- gcc-3.3-3.3ds5/debian/rules.d/binary-libobjc.mk > > +++ gcc-3.3-3.3ds5/debian/rules.d/binary-libobjc.mk > > @@ -15,6 +15,15 @@ > > $(PF)/lib/libobjc_gc.so.* > > endif > > > > +ifeq ($(biarch),yes) > > + dirs_lobjc += $(PF)/$(lib64) > > + files_lobjc += $(PF)/$(lib64)/libobjc.so.* > > +ifeq ($(with_objc_gc),yes) > > + files_lobjc += $(PF)/$(lib64)/libobjc_gc.so.* > > there is already a boehm-gc with 64bit support? I haven't tested boehm-gc, all I know is that it compiled without obvious problems. > > ifeq ($(with_java),yes) > > - CONFARGS += --enable-java-gc=boehm --enable-java-awt=xlib > > + CONFARGS += --enable-java-gc=boehm # --enable-java-awt=xlib > > hmm, that's bad. any way to disable this conditionally for the 64bit > build only? I didn't find any easy way to do it. The right solution is probably to have a proper test in libjava/configure.in that checks if libX11 is usable. Right now it only find libX11.so and the headers but breaks when attempting to link 64 bit awt code against -lX11. Arnd <><