> Rename "myClass" to be "ftClass" and then get rid of the TFormatter > variable. (The prefix "my" doesn't really describe the code in terms of > what it does. It describes the code in terms of who wrote it, and then > only when you already know who wrote it. It alienates everyone else > reading your code, too.)
i've just felt logical, to keep the original name from the initial example... (for comprehension) > > Now that you've gotten rid of the instance variable, get rid of the line > that calls the constructor. You're right ! i don't know why i miss that... but i have a question : can we do the same thing without using a general TFormatter class that declare a virtual method ? Thanks Cédric _______________________________________________ Delphi mailing list -> [email protected] http://lists.elists.org/cgi-bin/mailman/listinfo/delphi

