I was hoping if you could give a feedback on the progress

Hi Abhinav,

In addition to the notes I posted on JIRA, here's a few other things:

1) I'd like to look for an alternate way to code the handling of
   the "cols" variable. I think it's not the best technique to
   convert the array of column numbers into a string, and then convert
   the string back into an array of column numbers; it seems like
   we should be able to just keep the data in an array of column
   numbers and pass that around

2) Since we're doing some significant re-arranging of the
   getTriggerActionString() method, I'd like to re-work the
   large inline comments in that code; I find them very hard to read.

3) I'd like us to start thinking about how we can break this big
   patch down into several smaller patches, so that we can
   commit the overall work in several smaller changes, since this
   change has become fairly large.

4) I think we're going to need to add several new tests. I'd
   like to see different combinations of column references in
   the different parts of the trigger definition, and I'd like
   to see different data types for the columns so we get some
   feeling that we've added some good coverage here.

Overall, I think the work is going great. This is a pretty big
project, but I hope that you've learned a bunch about how Derby
handles dynamic query execution via triggers, and also about
how the Derby parser/compiler and query execution system are
implemented.

Fun stuff!

bryan

Reply via email to