[
https://issues.apache.org/jira/browse/DERBY-2261?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12481189
]
Laura Stewart commented on DERBY-2261:
--------------------------------------
I agree that it should be called only one thing. My vote is for clause.
In my research, VALUES is a form of a query, that takes "expressions" as it's
arguments. The typical SQL syntax is:
VALUES ( expression [, ...] ) [, ...]
Syntactically, VALUES followed by a list of expression is treated as equivalent
to
SELECT select_list FROM table_expression
VALUES is most commonly used as the data source in an INSERT statement, and
next most commonly as a subquery.
So, to me, it is a SQL clause, not an expression. "Construct" seems vague to
me.
Also for me, because VALUES is used within INSERT or as a subquery (and not as
a stand alone statement), I would not call it a statement.
If I can go to a command prompt and type VALUES (without it being side another
statement) and have data returned, then we should call it a statement.
> Questionable use of word "statement" in VALUES expression of Derby Reference
> Manual should be changed to "clause"
> -----------------------------------------------------------------------------------------------------------------
>
> Key: DERBY-2261
> URL: https://issues.apache.org/jira/browse/DERBY-2261
> Project: Derby
> Issue Type: Improvement
> Components: Documentation
> Environment:
> http://db.apache.org/derby/docs/dev/ref/rrefsqlj11277.html
> Reporter: Tomohito Nakayama
> Assigned To: Kim Haase
>
> "VALUES statement" in next one sentence in "VALUES expression" of Derby
> Reference manual should be changed to "VALUES clause".
> >You use a VALUES statement when you do not have a FROM clause.
> http://mail-archives.apache.org/mod_mbox/db-derby-dev/200701.mbox/[EMAIL
> PROTECTED]
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.