[ 
https://issues.apache.org/jira/browse/DERBY-2998?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12572556#action_12572556
 ] 

A B commented on DERBY-2998:
----------------------------

I have not had a chance to look at patch 17 yet, but I just had some follow-up 
feedback based on your recent comments:

> I'm not too satisfied with the variable name 'level' but it was the best I 
> could think of...

I think even something naive like "windowFunctionLevel" would be fine for now.  
I'd rather avoid the generic name "level" since there is already a "level" 
field that exists in FromTable.java, of which WindowNode is an indirect 
subclass (so if you're debugging, two different "level" fields show up).

> That again calls into the chain of WindowResultSets and PRNs, and eventually
> ends up in a a BulkTableScanResultSet.getNextRowCore() or similar to
> actually fetch *one* row.

If the intent is to fetch exactly *one* row, then would it be beneficial  to 
disable bulk fetching on the base table?  Otherwise, WindowResultSet may only 
want to fetch a single a row but, due to bulk fetching, we could end up with 16 
(or whatever the bulk size is).  Not a huge problem by any means, but a 
potential point for improvement if you haven't already dealt with it (maybe you 
have and I just missed it).

> It seems we don't take the fact that we know we have an ascending column
> into consideration any more (we used to). I'll have to have another look at 
> this.

Is this something that has been fixed with patch 17?  Or is it still work in 
progress? (I haven't tried it out yet).

> Add support for ROW_NUMBER() window function
> --------------------------------------------
>
>                 Key: DERBY-2998
>                 URL: https://issues.apache.org/jira/browse/DERBY-2998
>             Project: Derby
>          Issue Type: Sub-task
>          Components: SQL
>            Reporter: Thomas Nielsen
>            Assignee: Thomas Nielsen
>            Priority: Minor
>         Attachments: d2998-10.diff, d2998-10.stat, d2998-11.diff, 
> d2998-12.diff, d2998-12.stat, d2998-13.diff, d2998-13.stat, d2998-14.diff, 
> d2998-14.stat, d2998-15.diff, d2998-15.stat, d2998-16.diff, d2998-16.stat, 
> d2998-17.diff, d2998-17.stat, d2998-4.diff, d2998-4.stat, d2998-5.diff, 
> d2998-5.stat, d2998-6.diff, d2998-6.stat, d2998-7.diff, d2998-7.stat, 
> d2998-8.diff, d2998-8.stat, d2998-9-derby.log, d2998-9.diff, d2998-9.stat, 
> d2998-doc-1.diff, d2998-doc-1.stat, d2998-test.diff, d2998-test.stat, 
> d2998-test2.diff, d2998-test2.stat, d2998-test3.diff, d2998-test3.stat, 
> d2998-test4.diff, d2998-test4.stat, d2998-test6.diff, d2998-test7.diff
>
>
> As part of implementing the overall OLAP Operations features of SQL 
> (DERBY-581), implement the ROW_NUMBER() window function.
> More information about this feature is available at 
> http://wiki.apache.org/db-derby/OLAPRowNumber

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.

Reply via email to