The test plan was executed for Noble (24.04) and I confirm it was successful.
The package version used for the tests is the one proposed, as can be seen by
the output of apt-cache policy:
adsys:
Installed: 0.14.2~24.04
Candidate: 0.14.2~24.04
Version table:
*** 0.14.2~24.04 500
500 http://archive.ubuntu.com/ubuntu noble-proposed/main amd64 Packages
The following steps were executed:
1) Create a fresh VM with Ubuntu 24.04;
2) Get the source code of the proposed package;
3) Install the test dependencies: Go (snap version, as it's the most recent
one), pkg-config, libkrb5-dev, libsmbclient-dev, libglib2.0-dev, samba;
4) Go into the {where the source was downloaded}/adsys-0.14.2~22.04/internal/ad
directory;
5) Run the "TestTicketPath" 1000 times;
After step 5, all test runs were successful.
** Tags removed: verification-needed-jammy verification-needed-noble
** Tags added: verification-done-jammy verification-done-noble
--
You received this bug notification because you are a member of Desktop
Packages, which is subscribed to adsys in Ubuntu.
https://bugs.launchpad.net/bugs/2078473
Title:
Discovery of KRB5 ticket fails even if ticket is discoverable
Status in adsys package in Ubuntu:
Fix Released
Status in adsys source package in Jammy:
Fix Committed
Status in adsys source package in Noble:
Fix Committed
Bug description:
tracking bug
https://bugs.launchpad.net/ubuntu/+source/adsys/+bug/2078245
[ Impact ]
Even if the krb5 ticket is discoverable, the discovery fails (but
actually succeeded) So we cannot retrieve the policies or do any
action with the controller.
[ Test Plan ]
This is not something that can be easily reproduced in a real
environment, so the best approach to reproduce this issue is:
1. Get adsys codebase before the fix. You can do this by getting the
available version in the archive with the command:
apt source adsys
2. Run the TestTicketPath test located in internal/ad/krb5_test.go as many
times as needed to get the failure. To run the test, open a terminal and,
inside the mentioned directory, runs the test X times with the command:
go test -run TestTicketPatch -count X
3. The test can fail due to krb5_init_context changing the errno without
returning any error.
Without the patched version the test will fail after a number of runs.
With the patch, it will not fail.
[ Where problems could occur ]
We now reset errno to 0, because krb5_init_context() can alter it,
even if it succeeds. So the discovery always returns success when it
succeeds.
Worst case would be that discovery failed but errno is set to 0 but
this is handled earlier in the code.
To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/adsys/+bug/2078473/+subscriptions
--
Mailing list: https://launchpad.net/~desktop-packages
Post to : [email protected]
Unsubscribe : https://launchpad.net/~desktop-packages
More help : https://help.launchpad.net/ListHelp