> > From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED] > > > > A little bird told me that FD_ZERO() burns lots of cycles in > > apr_wait_for_io_or_timeout(). It turns out that this is an easy > > conversion to poll(), which doesn't have such overhead in the > > interface. > > > > This works for me with some testing (timeouts on read and write work > > for me). > > Can we remove the #ifdef's by just using apr_poll here? > > Ryan
I'd prefer not to do that. calling apr_poll will just add extra function call overhead. This code is pretty simple (ie, the #ifdef does not signicantly impact code readability). Bill