Hi, I found that we use both "nonexistent" and "non-existent" in our C++ code base. I think that we should use one of them instead of mixing them.
"nonexistent": * Public API: * cpp/src/plasma/: plasma::PlasmaErrorCode::PlasmaObjectNonexistent "non-existent": * Public API: * cpp/src/arrow/filesystem/: arrow::fs::FileType::NonExistent * Internal: * cpp/src/arrow/util/io_util.h: allow_non_existent * Test: * cpp/src/gandiva/tests/: non_existent_function Which should we use? (Personally, I prefer "nonexistent" to "non-existent".) Thanks, -- kou