[
https://issues.apache.org/jira/browse/ATLAS-5403?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]
Madhan Neethiraj reassigned ATLAS-5403:
---------------------------------------
Assignee: Madhan Neethiraj
> Docker: atlas-hadoop, atlas-hive containers startup fail
> --------------------------------------------------------
>
> Key: ATLAS-5403
> URL: https://issues.apache.org/jira/browse/ATLAS-5403
> Project: Atlas
> Issue Type: Bug
> Components: docker
> Reporter: Madhan Neethiraj
> Assignee: Madhan Neethiraj
> Priority: Major
>
> {{atlas-hive}} container startup failure is due to following issue in
> {{atlas-hadoop}} startup which resulted in failure in creation of HDFS
> directories for Hive (/tmp/hive, /user/hive/warehouse):
> {noformat}
> $ docker logs -f atlas-hadoop
> ...
> bash: line 1: /home/atlas/scripts/atlas-hadoop-mkdir.sh: Permission denied
> {noformat}
>
> In addition, {{atlas-hive}} container startup fails with the following
> database initialization error:
> {noformat}
> Metastore connection URL: jdbc:postgresql://atlas-db/hive
> Metastore Connection Driver : org.postgresql.Driver
> Metastore connection User: hive
> org.apache.hadoop.hive.metastore.HiveMetaException: Failed to get schema
> version.
> Underlying cause: org.postgresql.util.PSQLException : FATAL: password
> authentication failed for user "hive"
> SQL Error code: 0
> Use --verbose for detailed stacktrace.
> *** schemaTool failed ***
> {noformat}
--
This message was sent by Atlassian Jira
(v8.20.10#820010)