Redelivery policy's retryUntil option should be renamed as retryWhile
---------------------------------------------------------------------
Key: CAMEL-2889
URL: https://issues.apache.org/activemq/browse/CAMEL-2889
Project: Apache Camel
Issue Type: Improvement
Components: camel-core, camel-spring
Affects Versions: 2.3.0
Reporter: Claus Ibsen
Assignee: Claus Ibsen
Priority: Minor
Fix For: 2.4.0
The semantics of {{retryUnti}}l are a bit counter-intuitive. I would naturally
expect retryUntil(predicate) to mean _retry until predicate is true_, but it
actually means _retry until predicate is false_. If you change the name of the
option to {{retryWhile}}, you would get the natural interpretation _retry while
predicate is true_.
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.