[
https://issues.apache.org/jira/browse/CAMEL-3689?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12997465#comment-12997465
]
Claus Ibsen commented on CAMEL-3689:
------------------------------------
I think the adviceById and adviceByToString should be renamed to selectById and
selectByToString
> Let it be possible to add/remove/etc. nodes from a route when unit testing
> --------------------------------------------------------------------------
>
> Key: CAMEL-3689
> URL: https://issues.apache.org/jira/browse/CAMEL-3689
> Project: Camel
> Issue Type: New Feature
> Components: camel-core
> Reporter: Claus Ibsen
> Assignee: Claus Ibsen
> Fix For: 2.7.0
>
>
> Using the {{adviceWith}} when unit testing, it should be possible to add new
> nodes into the route, or remove, or replace etc.
> For example if you have a route for production, you may want to replace parts
> of the route during an integration test, in case that given part cannot be
> tested in the test environment.
> We need a DSL to more easily do this, so end users don't have to use low
> level RouteDefinition manipulation.
--
This message is automatically generated by JIRA.
-
For more information on JIRA, see: http://www.atlassian.com/software/jira