Hi

The WrappedFile seems like when people create a facade for another facade.

public interface WrappedFile<T> {
    T getFile();
}

That WrappedFile is not specific for a File, it could in fact be anything.
So I suggest to come up with a more generic name and API. I bet it
could come handy in another place in the jigsaw.

Could be

public interface WrappedObject<T> {
    T getObject();
}

Or

public interface WrappedEntity<T> {
    T getEntity();
}

Or

public interface Facade<T> {
    T getTarget();
}

Or something else.

Also any API in the root package should have javadoc, stating its
purpose and what it does.


-- 
Claus Ibsen
-----------------
FuseSource
Email: cib...@fusesource.com
Web: http://fusesource.com
Twitter: davsclaus, fusenews
Blog: http://davsclaus.blogspot.com/
Author of Camel in Action: http://www.manning.com/ibsen/

Reply via email to