Hi.

Although the list of successive changes might have been meaningful in separate
commits, it seems like noise in a single one (e.g. many of them signal a change
wrt to some previous state whose trace has been lost).  Obviously, repeating
"GEOMETRY-110" serves no purpose.
If possible (?), it would be neat to amend the log to just keep the first line.

Regards,
Gilles

Le dim. 28 avr. 2024 à 02:14, <mattjuntu...@apache.org> a écrit :
>
> This is an automated email from the ASF dual-hosted git repository.
>
> mattjuntunen pushed a commit to branch master
> in repository https://gitbox.apache.org/repos/asf/commons-geometry.git
>
>
> The following commit(s) were added to refs/heads/master by this push:
>      new 2f4e86b7 GEOMETRY-110: add ConvexHull3D using Quickhull algorithm
> 2f4e86b7 is described below
>
> commit 2f4e86b792693d4c2c0e5fb2c4f198541e1fecb6
> Author: Andreas Goß <75903169+agos...@users.noreply.github.com>
> AuthorDate: Sun Apr 28 02:14:00 2024 +0200
>
>     GEOMETRY-110: add ConvexHull3D using Quickhull algorithm
>
>     * GEOMETRY-110
>
>     Add ConvexHull3D class and tests.
>
>     * GEOMETRY-110
>
>     Return only an unmodifiable collection of facets.
>
>     * GEOMETRY-110
>
>     Test for a large number of points.
>
>     * Checkstyle Fix.
>
>     * GEOMETRY-110
>
>     Points are added to candidates again instead of a new point set.
>
>     * GEOMETRY-110
>
>     Only candidates points are distributed.
>
>     * GEOMETRY-110
>
>     Add Simplex type
>
>     * GEOMETRY-110
>
>     Create simplex while appending and cache it for later.
>
>     * GEOMETRY-110
>
>     Build simplex incrementially while appending points.
>
>     * GEOMETRY-110
>
>     Return facets as list and filter out duplicates in vertices.
>
>     * GEOMETRY-110
>
>     Returned collections have to be unmodifiable in public methods.
>
>     * GEOMETRY-110
>
>     Rename method and calculate maximum in a loop.
>
>     * GEOMETRY-110
>
>     Declare variable outside of loop.
>
>     * GEOMETRY-110
>
>     Rename methods.
>
>     * GEOMETRY-110
>
>     Replace bounds by array.
>
>     * GEOMETRY-110
>
>     Add check for appending a collection of points
>
>     * [GEOMETRY-110]
>
>     Delete hasOusidePoints and add exclusion for facets to spotbugs.
>
>     * [GEOMETRY-110]
>
>     Move isInside method into Facet class and reverse and rename it to 
> isOutside
>
>     * [GEOMETRY-110]
>
>     Replace vertexToFacetMap with edgeMap
>
>     * [Geometry-110]
>
>     Change loop for creating edges.
>
>     * [GEOMETRY-110]
>
>     Facets are all located through edge operations. The edges are oriented in 
> such a way, that neighbors share an edge in inverse orientation.
>
>     * [GEOMETRY-110]
>
>     Delete unnecessary debug code.
>
>     * [GEOMETRY-110]
>
>     Edges are oriented and lookup is done via an edgeMap. Each oriented edge 
> is unique in association with a facet. Each facet stores the maximum offset 
> and the associated point of outside points.
>
>     * [GEOMETRY-110]
>
>     - Rename Edge fields.
>     - Improve testing and assert all outputs of the algorithm.
>
>     * [GEOMETRY-110]
>
>     Check isDegenerate for all non-degenerate hulls.
>
>     * [GEOMETRY-110]
>
>     Even though the defined region is the same the number of facets can vary 
> depending on the execution order of the algorithm.
>
>     ---------
>
>     Co-authored-by: agoß <agoß@Goß>
>     Co-authored-by: Andreas Goss <ag...@itemis.com>
> ---
>  .../euclidean/threed/hull/ConvexHull3D.java        | 728 
> +++++++++++++++++++++
>  .../euclidean/threed/hull/package-info.java        |  25 +
>  .../euclidean/threed/hull/ConvexHull3DTest.java    | 276 ++++++++
>  .../resources/spotbugs/spotbugs-exclude-filter.xml |   5 +
>  4 files changed, 1034 insertions(+)
>
> [...]

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscr...@commons.apache.org
For additional commands, e-mail: dev-h...@commons.apache.org

Reply via email to