16/04/2021 13:00, Min Hu (Connor): > + if (iter == NULL) { > + RTE_ETHDEV_LOG(ERR, "Cannot init iterator for NULL iterator\n");
Don't you think it would be better as "Cannot init NULL iterator"? > rte_eth_iterator_cleanup(struct rte_dev_iterator *iter) > { > + if (iter == NULL) { > + RTE_ETHDEV_LOG(ERR, "Cannot iterator clear up for NULL iter\n"); Cannot clean up NULL iterator. > rte_eth_dev_owner_new(uint64_t *owner_id) > { > + if (owner_id == NULL) { > + RTE_ETHDEV_LOG(ERR, "Cannot get owner id for NULL param\n"); Cannot return owner id. > @@ -825,6 +864,11 @@ rte_eth_dev_get_port_by_name(const char *name, uint16_t > *port_id) > + if (port_id == NULL) { > + RTE_ETHDEV_LOG(ERR, "Cannot get port id for NULL param\n"); Cannot return port ID etc for all other messages Do you agree with the idea?