On Mon, 5 Oct 2015 11:26:08 -0400 Chas Williams <3chas3 at gmail.com> wrote:
> diff --git a/lib/librte_eal/common/include/rte_pci.h > b/lib/librte_eal/common/include/rte_pci.h > index 83e3c28..852c149 100644 > --- a/lib/librte_eal/common/include/rte_pci.h > +++ b/lib/librte_eal/common/include/rte_pci.h > @@ -161,6 +161,7 @@ struct rte_pci_device { > struct rte_pci_resource mem_resource[PCI_MAX_RESOURCE]; /**< PCI > Memory Resource */ > struct rte_intr_handle intr_handle; /**< Interrupt handle */ > struct rte_pci_driver *driver; /**< Associated driver */ > + char name[32]; Why not use IFNAMSIZ rather than magic constant here?