Hi Juraj!

I am not fussed about naming but I am certainly in favour of making things less confusing, so I am happy with this change.

On 19/04/2024 09:51, Juraj Linkeš wrote:
      @staticmethod
      def from_dict(
-        d: ExecutionConfigDict,
+        d: TestRunConfigDict,
          node_map: dict[str, Union[SutNodeConfiguration | 
TGNodeConfiguration]],
-    ) -> "ExecutionConfiguration":
+    ) -> "TestRunConfiguration":
<snip>
-    def copy_and_modify(self, **kwargs) -> "ExecutionConfiguration":
+    def copy_and_modify(self, **kwargs) -> "TestRunConfiguration":
<snip>
      @staticmethod
      def from_dict(d: ConfigurationDict) -> "Configuration":

Unrelated, but spark for an improvement. I have noticed these, not sure if there are more instances in the code. Shouldn't from_dict be a @classmethod instead of @staticmethod. In which case you could also use:

  from typing_extensions import Self

to replace all the class literals, example:

  @classmethod
  def from_dict(cls, d, node_map): -> Self:
    ...
    return cls(...) # initialise class with cls

  ...

  def copy_and_modify(self, **kwargs) -> Self:

Reply via email to