> > @@ -2267,5 +2183,47 @@ test_mem_ldx_dw_heap(void)
> > });
> > }
> >
> > -REGISTER_ATTIC_TEST(bpf_validate_mem_ldx_dw_heap_autotest,
> > - test_mem_ldx_dw_heap);
> > +static struct
> > +unit_test_suite test_bpf_validate_suite = {
> > + .suite_name = "Test BPF Validate Unit Test Suite",
> > + .unit_test_cases = {
> > + TEST_CASE(test_alu64_add_k),
Received some additional AI comments that are not visible in patchwork (?).
> **Missing blank line before suite definition**
>
> The static structure `test_bpf_validate_suite` should be separated from the
> preceding function `test_mem_ldx_dw_heap()` by a blank line for consistency
> with DPDK formatting conventions.
The model seems to be confused, the structure is clearly separated.
> **Extra space in structure name line**
This one is true BUT seems to be the majority style for some reason.
If fixed, this needs to be fixed in 49 other places.
> The suite name "Test BPF Validate Unit Test Suite" is somewhat redundant
> ("Test" appears twice). [...] This is a minor style preference; the current
> name is acceptable.
I mostly agree with this one, though some (not the majority) of the other
suites also use this style. But as model said, the current name is acceptable.
Net result, I do not plan to send another revision in the absence of other
comments or opinions.