Medvedkin, Vladimir, Sep 30, 2026 at 19:12:
Hi Robin,
As a general comment, do we really need these changes? ABI policy
recommends not to do so
https://doc.dpdk.org/guides-26.07/contributing/abi_policy.html#abi-changes
" Change the API only for significant reasons, such as performance
enhancements. Avoid API breakages due to changes such as reorganizing
public structure fields for aesthetic or readability purposes."
It isn't imperative, but since it does not break neither the API nor the
ABI: the enums are int and their names didn't change, I thought it would
be a nice clarification.
@@ -26,11 +26,11 @@ extern "C" {
/**
* rte_rib_get_nxt() flags
mode instead of flags
*/
-enum {
- /** flag to get all subroutes in a RIB tree */
+enum rte_rib_nxt_mode {
rte_rib_get_nxt_mode?
Ack
@@ -25,13 +25,13 @@ extern "C" {
#define RTE_RIB6_IPV6_ADDR_SIZE (RTE_DEPRECATED(RTE_RIB6_IPV6_ADDR_SIZE)
RTE_IPV6_ADDR_SIZE)
/**
- * rte_rib6_get_nxt() flags
+ * rte_rib6_get_nxt() mode
*/
-enum {
- /** flag to get all subroutes in a RIB tree */
+enum rte_rib6_nxt_mode {
rte_rib6_get_nxt_mode?
Ack.
--
Robin
# Membership dues are not refundable.