> -----Original Message----- > From: Jerin Jacob [mailto:jerin.jacob at caviumnetworks.com] > Sent: Friday, November 25, 2016 4:18 AM > To: Thomas Monjalon <thomas.monjalon at 6wind.com> > Cc: dev at dpdk.org; Richardson, Bruce <bruce.richardson at intel.com>; Van > Haaren, Harry <harry.van.haaren at intel.com>; hemant.agrawal at nxp.com; > Eads, > Gage <gage.eads at intel.com> > Subject: Re: [dpdk-dev] [PATCH 2/4] eventdev: implement the northbound > APIs > > On Wed, Nov 23, 2016 at 08:18:09PM +0100, Thomas Monjalon wrote: > > 2016-11-18 11:15, Jerin Jacob: > > > This patch set defines the southbound driver interface and > > > implements the common code required for northbound eventdev API > > > interface. > > > > Please make two separate patches. > > OK > > > > > > +#ifdef RTE_LIBRTE_EVENTDEV_DEBUG > > > +#define RTE_PMD_DEBUG_TRACE(...) \ > > > + rte_pmd_debug_trace(__func__, __VA_ARGS__) #else #define > > > +RTE_PMD_DEBUG_TRACE(...) #endif > > > > I would like to discuss the need for a debug option as there is > > already a log level. > > IMO, we don't need this. However, RTE_FUNC_PTR_OR_ERR_RET needs the > definition of RTE_PMD_DEBUG_TRACE inorder to compile. I think we can > remove it when it get fixed in EAL layer. > > > > > > +/* Logging Macros */ > > > +#define EDEV_LOG_ERR(fmt, args...) \ > > > > Every symbols and macros in an exported header must be prefixed by RTE_. > > > OK. I will fix it > > > > +/* Macros to check for valid device */ #define > > > +RTE_EVENTDEV_VALID_DEVID_OR_ERR_RET(dev_id, retval) do { \ > > > > Sometimes you use RTE_EVENT_DEV_ and sometimes RTE_EVENTDEV. > > (I prefer the latter). > > I choose the naming conversion based on the interface. API side it is > rte_event_ and driver side it is rte_eventdev_* > > rte_event_dev_count; > rte_event_dev_get_dev_id > rte_event_dev_socket_id; > rte_event_dev_info_get; > rte_event_dev_configure; > rte_event_dev_start; > rte_event_dev_stop; > rte_event_dev_close; > rte_event_dev_dump; > > rte_event_port_default_conf_get; > rte_event_port_setup; > rte_event_port_dequeue_depth; > rte_event_port_enqueue_depth; > rte_event_port_count; > rte_event_port_link; > rte_event_port_unlink; > rte_event_port_links_get; > > rte_event_queue_default_conf_get > rte_event_queue_setup; > rte_event_queue_count; > rte_event_queue_priority; > > rte_event_dequeue_wait_time; > > rte_eventdev_pmd_allocate; > rte_eventdev_pmd_release; > rte_eventdev_pmd_vdev_init; > rte_eventdev_pmd_pci_probe; > rte_eventdev_pmd_pci_remove;
For this last set, you probably are ok prefixing with just "rte_event_pmd_", and drop the "dev" as unnecessary. That makes everything have a prefix of "rte_event_" and thereafter dev, port, queue, or pmd as appropriate. /Bruce