For the special case of the logger, I kind of like it this way, because I
can turn it off just by commenting out a single line (to get rid of
unreferenced variable warnings), or add it by pasting in or uncommenting a
single line. In either case I don't have to worry about removing or adding
the import line separately, which can be quite far away if there are a lot
of imports.

On Tue, Jul 21, 2015 at 6:12 PM, Daniel Barclay <dbarc...@maprtech.com>
wrote:

> For logger member declarations, can we drop the current pattern of using
> qualified names (like this:
>
>   private static final org.slf4j.Logger logger =
> org.slf4j.LoggerFactory.getLogger(StoragePluginRegistry.class);
>
> ) and allow using imports and non-qualified names (as we do for almost
> everything else)?
>
>
> Using qualified names adds a lot of visual noise, and pushes the class
> literal farther to the right, making it easier to fail to notice that
> it doesn't match the containing class.
>
> Thanks,
> Daniel
> --
> Daniel Barclay
> MapR Technologies
>

Reply via email to