[
https://issues.apache.org/jira/browse/FELIX-3069?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13080618#comment-13080618
]
Richard S. Hall commented on FELIX-3069:
----------------------------------------
Understood that is seems "nice to have". My thinking is that
@Extract("namespace-uri") isn't really any simpler than
props.get("namespace-uri"). Ultimately, it is just a shifting of programming in
the Java language to programming in an annotation sub-language. Which is
ultimately why it doesn't seem to be worth it to me in this case. Perhaps
Clement has some thoughts.
> Support adapted bind/unbind method signature
> --------------------------------------------
>
> Key: FELIX-3069
> URL: https://issues.apache.org/jira/browse/FELIX-3069
> Project: Felix
> Issue Type: New Feature
> Components: iPOJO
> Reporter: Guillaume Sauthier
> Priority: Minor
>
> iPOJO already supports some basic bind/unbind methods signature (notification
> only, gives the service, with ServiceRef or not, with a Map or not).
> I would like to be able to have the service + any additional service property
> I'm interested in.
> Something like the following code:
> {noformat}
> public void bindAdapter(XmlAdapter adapter,
> @Extract("namespace-uri")) uri) {
> }
> {norformat}
> With @Extract (better name to be found) extracting the "namespace-uri"
> service property from the ServiceReference and giving it to this method.
--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira