I agree with Alex in most respects, but have a couple of other
suggestions, below.

I think the basic package should wrap (thinly, as possible) HTML/JS and
the SWF implementation mimic that but it doesn't necessarily need to have
the same names as HTML/JS uses and can be more platform agnostic.

I do think that we should refactor some things however. FlexJS "Core"
really needs to have all of the stuff that's universal and makes FlexJS
work. There are a number of interfaces in it that really belong in HTML
(basic). Imagine if we had a Basic project that included its own core,
shapes, and UI components. Then if you wanted to make a different set,
you'd use the universal Core and model your new set on Basic.

‹peter

On 7/21/16, 9:54 AM, "Alex Harui" <aha...@adobe.com> wrote:

>
>
>On 7/21/16, 3:00 AM, "Harbs" <ha...@printui.com> wrote:
>
>
>>3. I¹d like an interface which mimics the Flash APIs as closely as
>>possible. It might not make sense to have every element have a ³graphics²
>>object because it could inflate things unnecessarily, but I¹m thinking
>>that it might make sense to rename GraphicsContainer to CompoundGraphic
>>which would have all the drawing commands as first class methods. That
>>should make converting Flash objects to FlexJS objects pretty
>>straight-forward myObj.graphics.drawRoundedRect() would become
>>myObj.drawRoundedRect(). I¹d like to keep the actual method signatures as
>>similar as possible.
>
>Without thinking about it too much, my opinion is that the basic
>components job is to thinly wrap browser behavior so the JS output is as
>lightweight as possible, so I would be tempted to trade away Flash API
>compatibility to another SWC (which is happening in the MX/Spark port).
>
>My 2 cents,
>-Alex
>

Reply via email to