Timo Walther created FLINK-3489:
-----------------------------------

             Summary: Refactor Table API before merging into master
                 Key: FLINK-3489
                 URL: https://issues.apache.org/jira/browse/FLINK-3489
             Project: Flink
          Issue Type: Sub-task
          Components: Table API
            Reporter: Timo Walther


Before we merge the `tableOnCalcite` branch back into master, we should do some 
package/class refactoring. Here are some ideas:

- Move class {{TreeNode}} into {{expressions}} or its methods directly into 
{{Expression}}.
- Remove the {{org.apache.flink.api.table.trees}} package.
- Rename {{org.apache.flink.api.table.typeinfo}} to {{typeutils}} to be in sync 
with other Flink modules.
- Move {{TypeConverter}} to {{typeutils}}
- Remove {{ExpressionException}} it is currently only used by {{typeInfo()}} of 
{{Expression}}
- Remove {{typeInfo()}} of {{Expression}} and subclasses. It is not used.
- Add `ExecutionEnvironment` as parameter of `TableEnvironment` (necessary for 
Table API specific input formats) in order to not break the API in future?

Feel free to propose other changes.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to