huzeming created FLINK-22679:
--------------------------------

             Summary:  code optimization:Transformation.equals
                 Key: FLINK-22679
                 URL: https://issues.apache.org/jira/browse/FLINK-22679
             Project: Flink
          Issue Type: Improvement
          Components: API / DataStream
    Affects Versions: 1.13.0
            Reporter: huzeming


code optimization:Transformation.equals , line : 550
{code:java}
// old
return outputType != null ? outputType.equals(that.outputType) : 
that.outputType == null;
// new 
reutrn Objects.equals(outputType, that.outputType);{code}
I think after change  it will be more readable



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Reply via email to