-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/59326/
-----------------------------------------------------------

Review request for geode, Jinmei Liao, Jared Stewart, Ken Howe, and Patrick 
Rhomberg.


Bugs: GEODE-2934
    https://issues.apache.org/jira/browse/GEODE-2934


Repository: geode


Description
-------

GEODE-2934: refactor AnalyzeSerializablesJUnitTest and subclasses

Subclasses now only need to override the method "String getModuleName()" and 
return "geode-xxx" where "xxx" is the name of the geode module.

Eliminate lots of duplicated code, use SystemUtils for Java version check. 
Convert statics to member variables. Move setup code from tests to the @Before 
method. Use static imports to reduce line lengths. Generally make it easier to 
read and debug (this test gave me some issues during recent refactoring).


Diffs
-----

  geode-core/src/main/java/org/apache/geode/internal/lang/SystemUtils.java 
3485ede59 
  
geode-core/src/test/java/org/apache/geode/codeAnalysis/AnalyzeSerializablesJUnitTest.java
 5b78f065f 
  
geode-core/src/test/java/org/apache/geode/internal/lang/SystemUtilsJUnitTest.java
 8a83dc082 
  
geode-cq/src/test/java/org/apache/geode/codeAnalysis/AnalyzeCQSerializablesJUnitTest.java
 747dd8b4e 
  
geode-wan/src/test/java/org/apache/geode/codeAnalysis/AnalyzeWANSerializablesJUnitTest.java
 77c541cbd 


Diff: https://reviews.apache.org/r/59326/diff/1/


Testing
-------

precheckin in progress


Thanks,

Kirk Lund

Reply via email to