> On Oct. 20, 2016, 11:15 p.m., Kevin Duling wrote:
> > We've just stomped all over each other in RestSecurityIntegrationTest.  
> > Some time back, you'd refactored RestSecurityEndpointsDUnitTest to change 
> > it from a DUnit to an Integration test.  But in that change, you removed 
> > the abstract base class I'd placed doGet, doPut, etc., in to.
> > 
> > With the test I need for the new Swagger, I re-introduced the base class to 
> > avoid a lot of code duplication.  As a result, your changes are 
> > incompatible with the changes I have in GEODE-2014.
> > 
> > The changes aren't large, but I wanted to point out the merge conflict 
> > we're going to have.

I pulled all that utility methods into a GeodeRestClient object. It's easier to 
share code than an abstract class. I am gonna handle your pull request anyway. 
I can do the merge at that time.


- Jinmei


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/53079/#review153469
-----------------------------------------------------------


On Oct. 20, 2016, 10:31 p.m., Jinmei Liao wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/53079/
> -----------------------------------------------------------
> 
> (Updated Oct. 20, 2016, 10:31 p.m.)
> 
> 
> Review request for geode, Kevin Duling and Kirk Lund.
> 
> 
> Repository: geode
> 
> 
> Description
> -------
> 
> * add more test assertions.
> * fix legacy tests
> 
> 
> Diffs
> -----
> 
>   
> geode-assembly/src/test/java/org/apache/geode/rest/internal/web/GeodeRestClient.java
>  PRE-CREATION 
>   
> geode-assembly/src/test/java/org/apache/geode/rest/internal/web/RestSecurityIntegrationTest.java
>  6e91894c2c50e21c1fa250330119a7013f6b0fa5 
>   
> geode-web-api/src/main/java/org/apache/geode/rest/internal/web/controllers/CommonCrudController.java
>  30c8b3aa160648cae2ae2176e746ff987aba3aec 
>   
> geode-web-api/src/main/java/org/apache/geode/rest/internal/web/controllers/FunctionAccessController.java
>  e1ea1ade2e8633f983f60fcf3cb9b789cd9dc2f4 
>   
> geode-web-api/src/main/java/org/apache/geode/rest/internal/web/controllers/PdxBasedCrudController.java
>  ebb8ccc08fe1766d278eaeaf053365ad0e9afcfb 
>   
> geode-web-api/src/main/java/org/apache/geode/rest/internal/web/controllers/QueryAccessController.java
>  d13c99c11151355f3595718b15505db779d4161e 
> 
> Diff: https://reviews.apache.org/r/53079/diff/
> 
> 
> Testing
> -------
> 
> precheckin running
> 
> 
> Thanks,
> 
> Jinmei Liao
> 
>

Reply via email to